NHRP
NHRP (Next Hop Resolution Protocol) for NBMA networks
Within this page
NHRP RFCs (11)
RFC 2735: NHRP Support for Virtual Private Networks
Proposed Standard- B. Fox
- B. Petri
- December 1999
- IETF publication
- Internet Area
Abstract
The NBMA Next Hop Resolution Protocol (NHRP) is used to determine the NBMA subnetwork addresses of the "NBMA next hop" towards a public internetworking layer address. This document describes the enhancements necessary to enable NHRP to perform the same function for private internetworking layer addresses available within the framework of a Virtual Private Network (VPN) service on a shared NBMA network. [STANDARDS-TRACK]
Abstract
The NBMA Next Hop Resolution Protocol (NHRP) is used to determine the NBMA subnetwork addresses of the "NBMA next hop" towards a public internetworking layer address. This document describes the enhancements necessary to enable NHRP to perform the same function for private internetworking layer addresses available within the framework of a Virtual Private Network (VPN) service on a shared NBMA network. [STANDARDS-TRACK]
RFC 2677: Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP)
Proposed Standard- M. Greene
- J. Cucchiara
- J. Luciani
- August 1999
- IETF publication
- Internet Area
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. [STANDARDS-TRACK]
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in the Internet community. [STANDARDS-TRACK]
RFC 2603: ILMI-Based Server Discovery for NHRP
Proposed Standard- M. Davison
- June 1999
- IETF publication
- Internet Area
Abstract
This memo defines how ILMI-based Server Discovery, which provides a method for ATM-attached hosts and routers to dynamically determine the ATM addresses of servers, shall be used to locate NHRP servers. [STANDARDS-TRACK]
Abstract
This memo defines how ILMI-based Server Discovery, which provides a method for ATM-attached hosts and routers to dynamically determine the ATM addresses of servers, shall be used to locate NHRP servers. [STANDARDS-TRACK]
RFC 2583: Guidelines for Next Hop Client (NHC) Developers
Informational- R. Carlson
- L. Winkler
- May 1999
- IETF publication
- Internet Area
Abstract
This document provides guidelines for developers of the Next Hop Resolution Protocol Clients (NHC). The intent is to define the interaction between the NHC code and the TCP/IP protocol stack of the local host operating system. This memo provides information for the Internet community.
Abstract
This document provides guidelines for developers of the Next Hop Resolution Protocol Clients (NHC). The intent is to define the interaction between the NHC code and the TCP/IP protocol stack of the local host operating system. This memo provides information for the Internet community.
RFC 2520: NHRP with Mobile NHCs
Experimental- J. Luciani
- H. Suzuki
- N. Doraswamy
- D. Horton
- February 1999
- IETF publication
- Internet Area
Abstract
is document describes an extension to NHRP which would allow Mobile NHCs to perform a registration with and attach to an NHS in their home LIS in an authenticated manner. This memo defines an Experimental Protocol for the Internet community.
Abstract
is document describes an extension to NHRP which would allow Mobile NHCs to perform a registration with and attach to an NHS in their home LIS in an authenticated manner. This memo defines an Experimental Protocol for the Internet community.
RFC 2336: Classical IP and ARP over ATM to NHRP Transition
Informational- J. Luciani
- July 1998
- IETF publication
- Internet Area
Abstract
This document describes methods and procedures for the graceful transition from an ATMARP LIS to an NHRP LIS network model over ATM. This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
Abstract
This document describes methods and procedures for the graceful transition from an ATMARP LIS to an NHRP LIS network model over ATM. This memo provides information for the Internet community. It does not specify an Internet standard of any kind.
RFC 2332: NBMA Next Hop Resolution Protocol (NHRP)
Proposed Standard- J. Luciani
- D. Katz
- D. Piscitello
- B. Cole
- N. Doraswamy
- April 1998
- IETF publication
- Internet Area
Abstract
This document describes the NBMA Next Hop Resolution Protocol (NHRP). NHRP can be used by a source station (host or router) connected to a Non-Broadcast, Multi-Access (NBMA) subnetwork to determine the internetworking layer address and NBMA subnetwork addresses of the "NBMA next hop" towards a destination station. [STANDARDS-TRACK]
Abstract
This document describes the NBMA Next Hop Resolution Protocol (NHRP). NHRP can be used by a source station (host or router) connected to a Non-Broadcast, Multi-Access (NBMA) subnetwork to determine the internetworking layer address and NBMA subnetwork addresses of the "NBMA next hop" towards a destination station. [STANDARDS-TRACK]
RFC 2333: NHRP Protocol Applicability Statement
Proposed Standard- D. Cansever
- April 1998
- IETF publication
- Internet Area
Abstract
As required by the Routing Protocol Criteria [RFC 1264], this memo discusses the applicability of the Next Hop Resolution Protocol (NHRP) in routing of IP datagrams over Non-Broadcast Multiple Access (NBMA) networks, such as ATM, SMDS and X.25. [STANDARDS-TRACK]
Abstract
As required by the Routing Protocol Criteria [RFC 1264], this memo discusses the applicability of the Next Hop Resolution Protocol (NHRP) in routing of IP datagrams over Non-Broadcast Multiple Access (NBMA) networks, such as ATM, SMDS and X.25. [STANDARDS-TRACK]
RFC 2335: A Distributed NHRP Service Using SCSP
Proposed Standard- J. Luciani
- April 1998
- IETF publication
- Internet Area
Abstract
This document describes a method for distributing an NHRP service within a LIS. [STANDARDS-TRACK]
Abstract
This document describes a method for distributing an NHRP service within a LIS. [STANDARDS-TRACK]
RFC 1937: "Local/Remote" Forwarding Decision in Switched Data Link Subnetworks
Informational- Y. Rekhter
- D. Kandlur
- May 1996
- IETF publication
- Routing Area
Abstract
This document describes extensions to the IP architecture that relaxes these constraints, thus enabling the full utilization of the services provided by SVC-based Data Link subnetworks. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document describes extensions to the IP architecture that relaxes these constraints, thus enabling the full utilization of the services provided by SVC-based Data Link subnetworks. This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1735: NBMA Address Resolution Protocol (NARP)
Experimental- J. Heinanen
- R. Govindan
- December 1994
- IETF publication
- Routing Area
Abstract
This document describes the NBMA Address Resolution Protocol (NARP). NARP can be used by a source terminal (host or router) connected to a Non-Broadcast, Multi-Access link layer (NBMA) network to find out the NBMA addresses of the a destination terminal provided that the destination terminal is connected to the same NBMA network. This memo defines an Experimental Protocol for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This document describes the NBMA Address Resolution Protocol (NARP). NARP can be used by a source terminal (host or router) connected to a Non-Broadcast, Multi-Access link layer (NBMA) network to find out the NBMA addresses of the a destination terminal provided that the destination terminal is connected to the same NBMA network. This memo defines an Experimental Protocol for the Internet community. This memo does not specify an Internet standard of any kind.
Subscribe to NHRP
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.