key management

Key Management: key establishment, provisioning and storage

key management subjects:

key management RFCs (75)

Display RFCs as
  • RFC 10024: Post-Quantum Traditional (PQ/T) Hybrid Key Agreement Mechanisms for TLS 1.3

    Proposed Standard
  • RFC 9838: Group Key Management Using the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9678: Forward Secrecy Extension to the Improved Extensible Authentication Protocol Method for Authentication and Key Agreement (EAP-AKA' FS)

    Proposed Standard
  • RFC 9709: Encryption Key Derivation in the Cryptographic Message Syntax (CMS) Using HKDF with SHA-256

    Proposed Standard
  • RFC 9668: Using Ephemeral Diffie-Hellman Over COSE (EDHOC) with the Constrained Application Protocol (CoAP) and Object Security for Constrained RESTful Environments (OSCORE)

    Proposed Standard
  • RFC 9594: Key Provisioning for Group Communication Using Authentication and Authorization for Constrained Environments (ACE)

    Proposed Standard
  • RFC 9580: OpenPGP

    Proposed Standard
  • RFC 9583: Application Scenarios for the Quantum Internet

    Informational
  • RFC 9048: Improved Extensible Authentication Protocol Method for 3GPP Mobile Network Authentication and Key Agreement (EAP-AKA')

    Proposed Standard
  • RFC 8940: Extensible Authentication Protocol (EAP) Session-Id Derivation for EAP Subscriber Identity Module (EAP-SIM), EAP Authentication and Key Agreement (EAP-AKA), and Protected EAP (PEAP)

    Proposed Standard
  • RFC 8619: Algorithm Identifiers for the HMAC-based Extract-and-Expand Key Derivation Function (HKDF)

    Proposed Standard
  • RFC 8418: Use of the Elliptic Curve Diffie-Hellman Key Agreement Algorithm with X25519 and X448 in the Cryptographic Message Syntax (CMS)

    Proposed Standard
  • RFC 8125: Requirements for Password-Authenticated Key Agreement (PAKE) Schemes

    Informational
  • RFC 8121: Mutual Authentication Protocol for HTTP: Cryptographic Algorithms Based on the Key Agreement Mechanism 3 (KAM3)

    Experimental
  • RFC 8018: PKCS #5: Password-Based Cryptography Specification Version 2.1

    Informational
  • RFC 8031: Curve25519 and Curve448 for the Internet Key Exchange Protocol Version 2 (IKEv2) Key Agreement

    Proposed Standard
  • RFC 7914: The scrypt Password-Based Key Derivation Function

    Informational
  • RFC 7906: NSA's Cryptographic Message Syntax (CMS) Key Management Attributes

    Informational
  • RFC 7836: Guidelines on the Cryptographic Algorithms to Accompany the Usage of Standards GOST R 34.10-2012 and GOST R 34.11-2012

    Informational
  • RFC 7474: Security Extension for OSPFv2 When Using Manual Key Management

    Proposed Standard
  • RFC 7201: Options for Securing RTP Sessions

    Informational
  • RFC 7076: P6R's Secure Shell Public Key Subsystem

    Informational
  • RFC 6518: Keying and Authentication for Routing Protocols (KARP) Design Guidelines

    Informational
  • RFC 6278: Use of Static-Static Elliptic Curve Diffie-Hellman Key Agreement in Cryptographic Message Syntax

    Informational
  • RFC 6189: ZRTP: Media Path Key Agreement for Unicast Secure RTP

    Informational
  • RFC 6070: PKCS #5: Password-Based Key Derivation Function 2 (PBKDF2) Test Vectors

    Informational
  • RFC 6031: Cryptographic Message Syntax (CMS) Symmetric Key Package Content Type

    Proposed Standard
  • RFC 6063: Dynamic Symmetric Key Provisioning Protocol (DSKPP)

    Proposed Standard
  • RFC 6030: Portable Symmetric Key Container (PSKC)

    Proposed Standard
  • RFC 5998: An Extension for EAP-Only Authentication in IKEv2

    Proposed Standard
  • RFC 5904: RADIUS Attributes for IEEE 802.16 Privacy Key Management Version 1 (PKMv1) Protocol Support

    Informational
  • RFC 5869: HMAC-based Extract-and-Expand Key Derivation Function (HKDF)

    Informational
  • RFC 5749: Distribution of EAP-Based Keys for Handover and Re-Authentication

    Proposed Standard
  • RFC 5656: Elliptic Curve Algorithm Integration in the Secure Shell Transport Layer

    Proposed Standard
  • RFC 5649: Advanced Encryption Standard (AES) Key Wrap with Padding Algorithm

    Informational
  • RFC 5448: Improved Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA')

    Informational
  • RFC 5297: Synthetic Initialization Vector (SIV) Authenticated Encryption Using the Advanced Encryption Standard (AES)

    Informational
  • RFC 5295: Specification for the Derivation of Root Keys from an Extended Master Session Key (EMSK)

    Proposed Standard
  • RFC 5247: Extensible Authentication Protocol (EAP) Key Management Framework

    Proposed Standard
  • RFC 5275: CMS Symmetric Key Management and Distribution

    Proposed Standard
  • RFC 5169: Handover Key Management and Re-Authentication Problem Statement

    Informational
  • RFC 5021: Extended Kerberos Version 5 Key Distribution Center (KDC) Exchanges over TCP

    Proposed Standard
  • RFC 4962: BCP 132: Guidance for Authentication, Authorization, and Accounting (AAA) Key Management

    Best Current Practice
  • Informational
  • RFC 4535: GSAKMP: Group Secure Association Key Management Protocol

    Proposed Standard
  • RFC 4491: Using the GOST R 34.10-94, GOST R 34.10-2001, and GOST R 34.11-94 Algorithms with the Internet X.509 Public Key Infrastructure Certificate and CRL Profile

    Proposed Standard
  • RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)

    Informational
  • RFC 4304: Extended Sequence Number (ESN) Addendum to IPsec Domain of Interpretation (DOI) for Internet Security Association and Key Management Protocol (ISAKMP)

    Proposed Standard
  • RFC 4169: Hypertext Transfer Protocol (HTTP) Digest Authentication Using Authentication and Key Agreement (AKA) Version-2

    Informational
  • RFC 4107: BCP 107: Guidelines for Cryptographic Key Management

    Best Current Practice
  • RFC 4109: Algorithms for Internet Key Exchange version 1 (IKEv1)

    Proposed Standard
  • RFC 4046: Multicast Security (MSEC) Group Key Management Architecture

    Informational
  • RFC 3767: Securely Available Credentials Protocol

    Proposed Standard
  • RFC 3756: IPv6 Neighbor Discovery (ND) Trust Models and Threats

    Informational
  • RFC 3760: Securely Available Credentials (SACRED) - Credential Server Framework

    Informational
  • RFC 3634: Key Distribution Center (KDC) Server Address Sub-option for the Dynamic Host Configuration Protocol (DHCP) CableLabs Client Configuration (CCC) Option

    Proposed Standard
  • RFC 3562: Key Management Considerations for the TCP MD5 Signature Option

    Informational
  • RFC 3547: The Group Domain of Interpretation

    Proposed Standard

      Obsoleted by RFC 6407

  • RFC 3394: Advanced Encryption Standard (AES) Key Wrap Algorithm

    Informational
  • RFC 3310: Hypertext Transfer Protocol (HTTP) Digest Authentication Using Authentication and Key Agreement (AKA)

    Informational
  • RFC 3211: Password-based Encryption for CMS

    Proposed Standard

      Obsoleted by RFC 3369, RFC 3370

  • RFC 3217: Triple-DES and RC2 Key Wrapping

    Informational
  • RFC 3157: Securely Available Credentials - Requirements

    Informational
  • RFC 2785: Methods for Avoiding the "Small-Subgroup" Attacks on the Diffie-Hellman Key Agreement Method for S/MIME

    Informational
  • RFC 2786: Diffie-Helman USM Key Management Information Base and Textual Convention

    Experimental
  • RFC 2627: Key Management for Multicast: Issues and Architectures

    Informational
  • RFC 2631: Diffie-Hellman Key Agreement Method

    Proposed Standard
  • RFC 2522: Photuris: Session-Key Management Protocol

    Experimental
  • RFC 2408: Internet Security Association and Key Management Protocol (ISAKMP)

    Historic

      Obsoleted by RFC 4306

  • RFC 2367: PF_KEY Key Management API, Version 2

    Informational
  • RFC 2093: Group Key Management Protocol (GKMP) Specification

    Experimental
  • RFC 2094: Group Key Management Protocol (GKMP) Architecture

    Experimental
  • RFC 1949: Scalable Multicast Key Distribution

    Experimental
  • RFC 1422: Privacy Enhancement for Internet Electronic Mail: Part II: Certificate-Based Key Management

    Historic
  • RFC 1114: Privacy enhancement for Internet electronic mail: Part II - certificate-based key management

    Historic

      Obsoleted by RFC 1422

Subscribe to key management

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.