EdDSA
EdDSA (Edwards-curve Digital Signature Algorithm)
Within this page
EdDSA RFCs (14)
RFC 9591: The Flexible Round-Optimized Schnorr Threshold (FROST) Protocol for Two-Round Schnorr Signatures
InformationalRFC 9373: EdDSA Value for IPSECKEY
Proposed StandardRFC 9295: Clarifications for Ed25519, Ed448, X25519, and X448 Algorithm Identifiers
Proposed StandardRFC 9053: CBOR Object Signing and Encryption (COSE): Initial Algorithms
InformationalRFC 8709: Ed25519 and Ed448 Public Key Algorithms for the Secure Shell (SSH) Protocol
Proposed StandardRFC 8463: A New Cryptographic Signature Method for DomainKeys Identified Mail (DKIM)
Proposed StandardRFC 8420: Using the Edwards-Curve Digital Signature Algorithm (EdDSA) in the Internet Key Exchange Protocol Version 2 (IKEv2)
Proposed StandardRFC 8410: Algorithm Identifiers for Ed25519, Ed448, X25519, and X448 for Use in the Internet X.509 Public Key Infrastructure
Proposed StandardRFC 8419: Use of Edwards-Curve Digital Signature Algorithm (EdDSA) Signatures in the Cryptographic Message Syntax (CMS)
Proposed StandardRFC 8422: Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and Earlier
Proposed Standard- Obsoleted by RFC 9846
RFC 8080: Edwards-Curve Digital Security Algorithm (EdDSA) for DNSSEC
Proposed StandardRFC 8032: Edwards-Curve Digital Signature Algorithm (EdDSA)
InformationalRFC 8037: CFRG Elliptic Curve Diffie-Hellman (ECDH) and Signatures in JSON Object Signing and Encryption (JOSE)
Proposed StandardRFC 7479: Using Ed25519 in SSHFP Resource Records
Informational
Subscribe to EdDSA
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.